Requires java to be enabled.